Sicheres Ladegerät

  • Hallo allerseits,


    eigentlich hatte ich mir einen Chinesischen Superakku für den Betrieb der Montierung gekauft. War aber ein totaler Reinfall. Statt der angegebenen 16 Ah waren es nur knapp 3 Ah. Damit es nicht ganz raus geschmissenes Geld war, habe ich sie dann zum Betrieb meiner Wildkameras benutzt. Leider war die Lebensdauer doch recht kurz. So musste ich auf meine Bleiakku ausweichen. Da das Gelakkus sind, wollte ich die auf keinen Fall überladen. Also brauchte ich ein Ladegerät, was mit einem definierten Strom bis zur Endspannung lädt und sich dann abschaltet. Als Endspannung habe ich 2,2 V pro Zelle gewählt. Da ich genügend 12 Volt Netzteile habe, sollte das die Eingangspannung sein. Damit wäre auch ein Laden am Auto möglich.


    Zur Steuerung habe ich einen Arduino verwendet. Die Schaltung sieht so aus:


    schaltung.jpg


    Erst einmal eine Wurfschaltung zum Ausprobieren der Idee und des benötigten Programms:


    testaufbau.jpg


    Nach dem alles lief und zusammen gebaut war, sah dass dann so aus:


    lader_ger.jpg


    Es gehören zwei Programme dazu. Mit dem ersten (strom-spanning.ino) wird die Spannungsmessung eingestellt. Dazu startet man das Programm und schließt eine externe Spannungsquelle von 12 V an den Ausgang an. Sowohl der Strom und auch der Spannungsmesspunkt sollen jetzt den gleichen Wert, möglichst dicht an 12 V anzeigen und gleich sein. Da die Auflösung der analogen Eingänge nicht sehr groß ist, springen die Messwerte um zirka 15 mV.


    Sollten die Werte stark abweichen, Ist im Deklarationsteil der Programme ein Korrekturfaktor, den muss man dann etwas ändern.


    Das 2. Programm (lader.ino) ist dann das eigentliche Programm. Nach dem Starten wird man aufgefordert, den Akku anzuschließen. Ist die Spannung stabil, startet man mit der entsprechenden Taste den Ladevorgang.


    Über einen PM-Ausgang wird der Strom langsam erhöht und pendelt dann um den eingestellten Wert.


    Zur Dimensionierung ist nicht viel zu sagen. Die beiden Dioden links sind nur zur Sicherheit, dass der Arduino nicht mehr als 12 V (bei Autobatterie) erhält. Als Arduino habe ich die chinesische Version gewählt. Die ist nicht nur preiswerter, man kann die Drähte ein löten. Das ist deutlich sicherer als die Steckverbinder. Der Spannungswandler ist eine gekaufte Baugruppe.


    R1 20 KOhm; R2 10 KOhm; R3 1 Ohm; R4 5,5 KOhm; R5 460 Ohm; DR1 1mH (wahrscheinlich etwas zu klein); C1 47 myF; C2 500 myF; T1 2SA11200; der andere Transistor Bastelkiste; D1 1N5822 (sollte auf jeden Fall eine Schottky sein).


    Ansonsten lassen sich fast alle Anwendungsdaten im Deklarationsteil (ist beschriftet) variieren.


    Zum Schluss noch die beiden Programme:


    http://www.huk-2.de/lader/strom-spannung.ino  http://www.huk-2.de/lader/lader.ino

  • Und an der Stelle sollte ein Bild erscheinen, aber statt dessen kam diese Fehlermeldung:


    Unsichere Adressen („http://“) wurden für Bilder deaktiviert, bitte verwenden Sie nur sichere Adressen („https://“).


    Wäre schön wenn man das mal ändern könnte. Wenn ich die Adresse auf https:// geht es auch nicht. Da kommt dann:

    Moin Hans_Ulrich


    das wird nicht mehr geändert. Habe ich hier auch angekündigt:



    RE: Viel tut sich ja hier nicht mehr. Was tun?


    Entweder funktionierendes Https, Galerie oder als Dateianhang ins System laden.


    CS

    Chris

    Die Realität ist nur ein Spiegelbild unendlicher Möglichkeiten

  • Hallo Chris


    auch eine Bitte:


    >> bindet externe Bildlinks bitte über HTTPS ein,


    und wie macht man das?

    Mit freundlichen Grüßen


    Hans-Ulrich


    -------------------------------------------------------------------------------------


    Eine wichtige Eigenschaft von Meinungen ist, dass sie sich unterscheiden können.


    -------------------------------------------------------------------------------------


    Verzeichnis-Sonnenbeobachtung-Bilder-und-Bildbearbeitung

  • und wie macht man das?

    Das ist einfach. Den Bilderlink anstelle mit http mit https am Anfang versehen. Funktioniert allerdings nur, wenn der Server das auch bereitstellt.

    Das ist mittlerweile eigentlich schon fast zum standard geworden.

    Ich muß es z.b. anbieten, da Daten erhoben werden bei der Registrierung usw..

    Die Realität ist nur ein Spiegelbild unendlicher Möglichkeiten

  • Ich habe jetzt mal in alten Beiträgen nachgesehen. Dort sind die Bilder als Link (mit https) vorhanden. Beim Anklicken werden die Bilder gezeigt. Stelle ich jetzt aber ein Bild ein, wird zwar der Link angezeigt aber beim Bild kommt eine Fehlermeldung.

    Mit freundlichen Grüßen


    Hans-Ulrich


    -------------------------------------------------------------------------------------


    Eine wichtige Eigenschaft von Meinungen ist, dass sie sich unterscheiden können.


    -------------------------------------------------------------------------------------


    Verzeichnis-Sonnenbeobachtung-Bilder-und-Bildbearbeitung

  • Hallo allerseits,


    ich habe die Lösung gefunden. In der Quelle muss "https" und in der Verlinkung "http" stehen. Dann wird das Bild als Link angezeigt und der Link lässt sich öffnen.

    Mit freundlichen Grüßen


    Hans-Ulrich


    -------------------------------------------------------------------------------------


    Eine wichtige Eigenschaft von Meinungen ist, dass sie sich unterscheiden können.


    -------------------------------------------------------------------------------------


    Verzeichnis-Sonnenbeobachtung-Bilder-und-Bildbearbeitung

  • Und wenn es jetzt Chris noch gelingt, die funktionierenden Links direkt in Bilder umzuwandeln, dann wäre das nicht schlecht.

    Mit freundlichen Grüßen


    Hans-Ulrich


    -------------------------------------------------------------------------------------


    Eine wichtige Eigenschaft von Meinungen ist, dass sie sich unterscheiden können.


    -------------------------------------------------------------------------------------


    Verzeichnis-Sonnenbeobachtung-Bilder-und-Bildbearbeitung